OpenGL Launch Problem

Hello Gents and Gentets!

I have been online for some time now searching for a remedy to a rather irksome problem of mine. earlier today, I could run Half Life in regular old OpenGL mode, as always. This changed when I deleted my user profile (On Windows XP) and created a new one. Now, whenever i begin Half Life i get an error message stating that "The specefied video mode is not supported.

               The game will now run in software mode"

The computer is stubbornly adamant regarding this, and i have tried various solutions proposed to other people both on this forum and others.

Some include:Placing the nvoglnt.dll file (From WINDOWS/SYSTEM32) in the gldrv folder and changing the text in the drvmap from "Default Default

                                gldrv/3dfxgl.dll 3Dfx Mini Driver" 

To

"Default Default gldrv/nvoglnt.dll OpenGL Driver".

Setting launch options through steam to attempt to force the mode (-gl)

Uninstalling drivers, rebooting in safe mode and cleaning with Driver Cleaner Pro, then reinstalling drivers from Nvidia. I have also upgraded to DX10 in attempts to rectify this issue.

My Graphics card is an ancient Nvidia MX, you may all laugh at me for that :). Until earlier today, as i said, this was not a program and opengl ran fine at 1152 screen resolution.

Any help will be greatly appreciated,

Thank you all kindly for reviewing my problem.

Arf The Fiendish

Oh noes! You're not a Member!

Want access to cool stuff? As a member you can:

  • Post. Give the submitter your thoughts on this Thread.
  • Say Thanks. Show your appreciation by sending the submitter points.
  • Stamp Posts. Let other posters know what you think of their posts.
  • Rate. Give this Thread a rating out of 10.
  • Flag. Alert moderators and warn members of a problem with this Thread.
  • Vote. Vote the submitter for the Monthly Awards.
  • Subscribe. Get notified when this submitter submits again.

Interested? Register or Login

  • You must be a member

Replies

  • N3Z90 avatar
    Availability
    Offline
    Points Level
    Beggar Points Level icon
    Beggar
    74 points
    Exemplary Feedback Level
    Helper Exemplary Feedback Level icon
    Helper
    1 EF's
    Account Age Level
    Elder Age Level icon
    Elder
    7 years old
    Clearance Level
    Member Clearance Level icon
    Member
    • Report icon
    6 years ago:

    Have you tried to launch the game with -w 800 -h 600 for example?

    The graphic settings are saved in the registry at HKEY_CURRENT_USER\Software\Valve\Half-Life\Settings maybe these settings are damaged or gone

    you could also type: -gldrv nvoglnt.dll in the startparameters

    Have you tried reinstalling it?

    Banned
  • Arf the Fiendish avatar
    Availability
    Offline
    Account Age Level
    Elder Age Level icon
    Elder
    6 years old
    Clearance Level
    Member Clearance Level icon
    Member
    • Report icon
    6 years ago:

    As i said Reaper, I already did that. Pehaps you should have read the entire post? :P

  • Pazzo avatar
    Availability
    Offline
    Account Age Level
    Elder Age Level icon
    Elder
    7 years old
    Clearance Level
    Member Clearance Level icon
    Member
    • Report icon
    6 years ago:

    Lol, Reinstall it, That tends to fix things

    Lolumad? avatar
    User Title
    Lolumad?
  • Arf the Fiendish avatar
    Availability
    Offline
    Account Age Level
    Elder Age Level icon
    Elder
    6 years old
    Clearance Level
    Member Clearance Level icon
    Member
    • Report icon
    6 years ago:

    Reinstalling it did not work, nor did the -gldrv nvoglnt.dll command. What is this about the registry? please elabourate. i've never heard of it before.

  • N3Z90 avatar
    Availability
    Offline
    Points Level
    Beggar Points Level icon
    Beggar
    74 points
    Exemplary Feedback Level
    Helper Exemplary Feedback Level icon
    Helper
    1 EF's
    Account Age Level
    Elder Age Level icon
    Elder
    7 years old
    Clearance Level
    Member Clearance Level icon
    Member
    • Report icon
    6 years ago:

    Start --> execute: type "regedit" without the ""

    go to that directory: HKEY_CURRENT_USER\Software\Valve\Half-Life\Settings there are the display settings with your current resolution saved

    it should be like that (that would be a resolution of 1600x1200):

    "ValveKey"="" "EngineDLL"="hw.dll" "ScreenWindowed"=dword:00000000 "CrashInitializingVideoMode"=dword:00000000 "ScreenWidth"=dword:00000640 "ScreenHeight"=dword:000004b0 "ScreenBPP"=dword:00000020 "User Token 2"="" "User Token 3"="" "EngineD3D"=dword:00000000 "io"="1215446588" "DELV"=dword:00000002 "yeK1"="D5307FFCAD2D0F27543A46F1858663E9B57E618D3F32E5A99798E4A0F9E1D6F49C547DA12760CE8F0227BA79839C4C090492C00652B 98AEE416133A3474C69038DEC555C3ECFA8FBEE6731E3A0D3D1E4FC120CA5BC6E07F250DAD93768A886F0B118D32C9BDAE904F486F7AECD863B7CBFDCB2EC4B545A4B8D39578DB23861" "yeK2"="655960B8A01EBD9B3A2D54EB77D08E970206AC7FB8EE5AE1476B8A20F844DFE5A6FF8C14140FA0FE7A4069B2A70AE94E74DBC17DE0AB"

    but these settings should be there because you reinstalled it.

    BTW do other games with opengl work?

    Banned
  • Arf the Fiendish avatar
    Availability
    Offline
    Account Age Level
    Elder Age Level icon
    Elder
    6 years old
    Clearance Level
    Member Clearance Level icon
    Member
    • Report icon
    6 years ago:

    The "Enginedll=hw.dll line read "Enginedll=sw.dll" instead of what it should have been. after rectifying that, i updated the Nvoglnt.dll file with the newest one and tried running OpenGl on 32 bit textures with high resolution. It worked :) thank you all so much for your help, i can now enjoy my SvenCoop and Half-Life related adventures once again!

    Hope this thread helps others with the same issue!

    Arf

  • You must be a member

Submitter

Arf the Fiendish avatar
Availability
Offline
Account Age Level
Elder Age Level icon
Elder
6 years old
Clearance Level
Member Clearance Level icon
Member

Arf the Fiendish

Stats

Post Count
6
ViewCount
9,988
Date Added
6 years ago
Date Modified
6 years ago

Share

Code to use:

More embeddable images

Bookmark and Share